Slack Channel / Joining foundation?

In order to access the slack channel I understand that one needs to join the foundation. However, form seems not functional, and when trying to fill it, you are redirected to a broken page.
Can these be fixed? Or I am the only one who has this issue?

1 Like

It looks like there’s a certificate error on the sign-up form that may be related.

I just sent a message via the contact form to let the F# Software Foundation team know.

Just about to report as well.

I’m working on it - Our host changed their system (without notifying us :rage:), and I’m working with them on fixing stuff on our end to get it working.

I believe the signups should function properly now. The certificate errors should go away (it sounds like Monday, from what I’ve told) very soon, as well, but I have no control over making that happen more quickly. I’ve requested this be prioritized, so we’ll see.

Sorry for the confusion and issues.

-Reed

3 Likes

Seems like the things are fixed right now. Thanks.

After the website was working again, I tried to join the foundation. I thought I did but realized there wasn’t any follow up email. I just tried again and it hangs on ‘Saving…’

2021-01-02 14_58_45-Window

I thought maybe I could join through donating, but that doesn’t appear to be the case. The money went through though.