Is this a problem (outdated indirect dependencies)?

(An inexperience DotNet/FSharp developer)

Hi

I’ve updated a project I’m working on to .Net 6.0. However, running dotnet paket outdated there were a lot of old (FSharp 5) dependencies. I’ve updated all the direct dependencies to their latest versions but I still get the following list:

 pwsh  dotnet paket outdated
Paket version 6.2.1+c82f25d6c324024cbd231df154a447a117c2546e
Resolving dependency graph...
Outdated packages found:
  Group: Main
    * Microsoft.NETCore.Platforms 5.0.2 -> 6.0.1
    * Microsoft.Win32.SystemEvents 5.0 -> 6.0.0
    * NuGet.Frameworks 5.11 -> 6.1.0
    * System.Collections.Immutable 5.0 -> 6.0.0
    * System.Configuration.ConfigurationManager 5.0 -> 6.0.0
    * System.Drawing.Common 5.0.2 -> 6.0.0
    * System.Reflection.Metadata 5.0 -> 6.0.0
    * System.Runtime.CompilerServices.Unsafe 5.0 -> 6.0.0
    * System.Security.AccessControl 5.0 -> 6.0.0
    * System.Security.Cryptography.ProtectedData 5.0 -> 6.0.0
    * System.Security.Permissions 5.0 -> 6.0.0
    * System.Windows.Extensions 5.0 -> 6.0.0
Total time taken: 1 minute, 34 seconds

There seems to still be many outdated dependencies (which seems to be important). Querying the reason for the old versions it seems that it’s because of a few dependencies which have their latest version compiled against .Net 5 and this is the dependencies they use.

My questions is:

  1. Is tis a problem? Could it lead to incompatible versions in runtime or indeterministic behavior.
  2. Can (and should) I somehow force using the latest versions of these libraries?

Thanks in advance

Haim